Rocksolid Light

Welcome to novaBBS (yes, it's Usenet)

register  nodelist  faq  

I profoundly believe it takes a lot of practice to become a moral slob. -- William F. Buckley


rocksolid / Helpdesk / latest

Re: Screwed Up With Permissions

rocksolid.shared.helpdesk

Posted: 11 Hours 20 Minutes ago by: Anonymous

Do you get 'Permission denied' or some other error message when trying as root? Unless you have some specific reason to change permission on things, it's usually best to leave them alone. Debian does a reasonable job of setting proper

Re: Screwed Up With Permissions

rocksolid.shared.helpdesk

Posted: 11 Hours 53 Minutes ago by: Anonymous

And yay! Guess what! I just screwed up even more! I screwed up so much that the root user doesn’t even have permissions anymore! How I just mess things up... I honestly don’t really know what I did. I changed permissions for certain

Re: Screwed Up With Permissions

rocksolid.shared.helpdesk

Posted: 15 Hours 2 Minutes ago by: Anonymous

chmod should do the trick. If you already changed the perms that means you have root access, so as root just use chmod (man chmod) and it will be fine. And only run as root to do some task, then switch back to a regular user. We've all

Re: Screwed Up With Permissions

rocksolid.shared.helpdesk

Posted: 20 Hours 32 Minutes ago by: Anonymous

I have fixed it through recovery mode. Sorry. I just got a little panicked.

Screwed Up With Permissions

rocksolid.shared.helpdesk

Posted: 21 Hours 24 Minutes ago by: Anonymous

I think I really need help. I'm working on a Debian 10 system, and I accidentally changed the permissions of the /usr directory to 764. Now I can't get back in. Can anyone please tell me how to fix this?

Re: Do you have a good Ddos tool?

rocksolid.shared.helpdesk

Posted: 1 Month 7 Days ago by: Anonymous

Look up the Kali Linux distribution. To give a more specific answer: what kind of service do you want to dos ?

Do you have a good Ddos tool?

rocksolid.shared.helpdesk

Posted: 1 Month 7 Days ago by: Anonymous

Hey I am serching for a good and working Ddos tool.

Re: Index.php

rocksolid.shared.helpdesk

Posted: 1 Month 18 Days ago by: Anonymous

lol, we have all been there. in fact, this kind of thing happens a lot to me. i have just got better and better in finding the shit, and i also changed some of my coding habits as a result.

Re: Websites not loading on my tor browser?

rocksolid.shared.helpdesk

Posted: 1 Month 18 Days ago by: Anonymous

Do you need to prove you are 18 to use an exchange wallet only? I would think you can download a free wallet app without identifying yourself. I have not done this so maybe I'm completely wrong, but why do you need to be 18? https://www

Re: Index.php

rocksolid.shared.helpdesk

Posted: 1 Month 18 Days ago by: Anonymous

That happens to all of us. Mismatched brackets in code drive me nuts! We're not smarter than you. It's just how stuff gets figured out.

Re: Websites not loading on my tor browser?

rocksolid.shared.helpdesk

Posted: 1 Month 18 Days ago by: Anonymous

Guys pls i need to find some wallet that i can use to put in cardano, but i am not fully 18 yo. do i have to wait or maybe i can use fake id?

Re: Index.php

rocksolid.shared.helpdesk

Posted: 1 Month 18 Days ago by: Anonymous

SOLVED. What was the problem? I kept on confusing the screen of death as a problem with the FPM. So I kept on tampering with the configuration files that eventually resulted in many different kinds of errors. Took me days of a lot of stres

Re: None

rocksolid.shared.helpdesk

Posted: 1 Month 19 Days ago by: Retro Guy

Sometimes nginx makes my brain hurt, lol :) I don't have anything with the snippets line. Here's what I use: location ~ .php$ { fastcgi_split_path_info ^(.+.php)(/.+)$; fastcgi_pass unix:/run/php/php7.0-

Re: index.php

rocksolid.shared.helpdesk

Posted: 1 Month 19 Days ago by: Anonymous

Remove it from where ? the config file ? This means usually that the backend (so php in your case) does not answer to the request. This could have a bunch of reasons, like: -service not running -service is overloaded -not enough ram -yo

None

rocksolid.shared.helpdesk

Posted: 1 Month 19 Days ago by: Anonymous

interesting, i don't use this at all (i mean fastcgi_split_path_info). instead, i use this construction (and it works well for me): location ~ (index|register)\.php$ { include snippets/fastcgi-php.conf; f

Re: Index.php

rocksolid.shared.helpdesk

Posted: 1 Month 19 Days ago by: Retro Guy

fastcgi_split_path_info is where it identifies that it's a php script and breaks the script part of the line apart from the rest of the url. Your line (below) looks ok. Take the two lines above out of 'location / { }' so: listen 8

Re: Index.php

rocksolid.shared.helpdesk

Posted: 1 Month 19 Days ago by: Anonymous

Yup. I have installed it, it's properly running, and fastcgi_pass matches www.conf. Although, I get a "File Not Found." error and a "404 Forbidden" error when I change the fastcgi_split_path_info information. I also sometimes get a "FastCGI

Re: Index.php

rocksolid.shared.helpdesk

Posted: 1 Month 20 Days ago by: Retro Guy

Are you using php-fpm? If so, have you specifically installed it and is it running? default.conf should point .php to it and fastcgi_pass should match php-fpm setting: location ~ .php$ { fastcgi_split_path_info ^(.+.php)

Re: Index.php

rocksolid.shared.helpdesk

Posted: 1 Month 20 Days ago by: Anonymous

Also, if I remove the Nginx error message, I get a 502 Bad Gateway error. Not sure if that information was really needed, though.

Re: Index.php

rocksolid.shared.helpdesk

Posted: 1 Month 20 Days ago by: Anonymous

I restarted the services many times (both Nginx and the FPM) and index.php is prioritized over index.html. -_-

Re: Index.php

rocksolid.shared.helpdesk

Posted: 1 Month 20 Days ago by: Anonymous

Sounds to me like you have done all the right steps. First question: did you restart the service to apply the changes you have made ? Second question: do you maybe have both index.html and index.php in your directory, and index.html at the

Index.php

rocksolid.shared.helpdesk

Posted: 1 Month 20 Days ago by: Anonymous

Hello. I’ve run into some trouble with Nginx. I’ve set up Nginx and for some reason, Nginx is only taking in index.html, not index.php. I’ve included index.php in the index directive and also enabled Nginx php support in the default.c

Re: First time

rocksolid.shared.helpdesk

Posted: 2 Months 19 Days ago by: Anonymous

Aren't you posting this using tor? i2p Web forums: def2.i2p def3.i2p def4.i2p retrobbs.i2p novabbs.i2p rslight.i2p Tor Web Forums: z5bqfv5v75kxy7pj.onion dkzerogt6z6ybhcj.onion j7zbybfl5ho2rta3.onion Clearnet Web Forums: www.rocksolidb

Re: First time

rocksolid.shared.helpdesk

Posted: 2 Months 19 Days ago by: Anonymous

same answer: the tor browser bundle (https://www.torproject.org/download/) A part of these forums are in the darknet as well, btw (for instance the frontend I just use for this post). Welcome to the better part of the internets.

First time

rocksolid.shared.helpdesk

Posted: 2 Months 19 Days ago by: Anonymous

From past 4 to 5 years i have been coping up with privacy and knowing about the dark web. Many people claimed that its bad. But it depends on the usage. I wanted to know about this dark web and deep web and how can we access using some spe

Re: clearnetsite not loading

rocksolid.shared.helpdesk

Posted: 3 Months 4 Days ago by: Anonymous

Anything for the profit nowadays. I guess that's a way to get rid of the people who disagree with you... Anyway, thanks for telling me all that was going on. I'm not exactly up-to-date with the news on Tor. Do you know any sites I can ofte

None

rocksolid.shared.helpdesk

Posted: 3 Months 4 Days ago by: Anonymous

whoa

Re: clearnetsite not loading

rocksolid.shared.helpdesk

Posted: 3 Months 23 Days ago by: Retro Guy

pita = pain in the ass :) Censorship online has gone mainstream over the past few years. The number of people that feel that is the way to win an argument (by shutting down those who disagree) is appalling. If it takes getting voices

Re: Clearnetsite not loading

rocksolid.shared.helpdesk

Posted: 3 Months 24 Days ago by: Retro Guy

That's exactly what I was trying to avoid by blocking users by sessions instead of ip addresses, which seems to be working well. Years ago I ran a popular clearnet site and blocked a few ip addresses of pita users and then realized I wa

Re: Clearnetsite not loading

rocksolid.shared.helpdesk

Posted: 3 Months 24 Days ago by: Anonymous

If this is on purpose, they are not trying but successfully doing it. :-) Could be though that they just do IP based rate limiting, in which case a dos attack coming from one exit node would prevent you to access reddit from the same exit n

Re: Clearnet site not loading

rocksolid.shared.helpdesk

Posted: 3 Months 24 Days ago by: Anonymous

I get the same. Maybe reddit is trying to block tor users?

Re: Clearnet site not loading

rocksolid.shared.helpdesk

Posted: 3 Months 24 Days ago by: Anonymous

It gives 503s when the access is done via tor (still today). That could be part of an ongoing ddos and/or the resulting counter measures. I could access the site just fine without tor. meeh...I hate it when clearnet sites cannot be visited

Re: Clearnet site not loading

rocksolid.shared.helpdesk

Posted: 3 Months 24 Days ago by: Anonymous

I haven't noticed that. It's working for me. I think ddos can cause a 503 by overloading the server, but it's working now and was yesterday anyway.

Clearnet site not loading

rocksolid.shared.helpdesk

Posted: 3 Months 25 Days ago by: Anonymous

since yesterday, I only get 503s. is reddit under attack as well ?

Re: Onion site not loading

rocksolid.shared.helpdesk

Posted: 3 Months 25 Days ago by: Anonymous

Kind of makes me glad I've waited moving to v3: https://www.reddit.com/r/TOR/comments/kunv6n/v3_onion_workaround/

Re: Onion site not loading

rocksolid.shared.helpdesk

Posted: 3 Months 25 Days ago by: Anonymous

https://gitlab.torproject.org/tpo/core/tor/-/issues/40237 https://darknetdaily.com/?p94

None

rocksolid.shared.helpdesk

Posted: 3 Months 26 Days ago by: Anonymous

Facts, please. For me both v3 and v2 services are working again. Facts or links, please.

Re: Onion site not loading

rocksolid.shared.helpdesk

Posted: 3 Months 26 Days ago by: Guest

Coup in progress USA. v3 Tor not woking. Major attack on some i2p routers too. -- Posted on def3

Re: Onion site not loading

rocksolid.shared.helpdesk

Posted: 3 Months 27 Days ago by: Anonymous

The tor network is under attack currently, it started around 2 days ago, see one of the threads on tor (http://def2.i2p/to/res/431.html).

Re: Onion site not loading

rocksolid.shared.helpdesk

Posted: 3 Months 27 Days ago by: Anonymous

Have you looked at the web server logs? Did you change any settings, like what interface the web server is bound to? I assume when you went onto your "site on another machine", that means not through tor. So if your site is only respon

Onion site not loading

rocksolid.shared.helpdesk

Posted: 3 Months 27 Days ago by: Anonymous

I was working on a personal onion site that uses Php, and everything was fine until about two days ago. My personal onion site suddenly isn't loading up on Tor. It says "The connection has timed out The server at (mysite).onion is taking to

Re: Fonts in tor browser

rocksolid.shared.helpdesk

Posted: 4 Months 6 Days ago by: Anonymous

The tor browser can load fonts, you can test it here on def4 for example: http://acmsrfsbsogtuhvk.onion/bbx/ Could it be that the url needs to be expressed differently ? You do: src: url('MyFont.eot'); Maybe it must be: src: url('/fon

Fonts in tor browser

rocksolid.shared.helpdesk

Posted: 4 Months 6 Days ago by: Anonymous

@font-face{ font-family: "MyFont"; src: url('MyFont.eot'); src: url('MyFont.eot?#iefix') format('embedded-opentype'), url('MyFont.woff2') format('woff2'), url('MyFont.woff') format('woff'), url('MyFont.ttf') form

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 4 Months 8 Days ago by: Neodome Admin

If you will ever need it in the future, INN allows to use IHAVE on per-user basis. You don’t have to turn it on for everyone.

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 4 Months 10 Days ago by: trw

Thanks Neodome, for the explanation, it is pretty clear to me. And yes, it is understandable that it is not used if it enables the kind of forgery you describe. Luckily, with the use of rpost, I don't need it.

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 4 Months 10 Days ago by: Neodome Admin

It probably was kept for backwards compatibility with software that was in use back in old days. As far as I know, none of the major newsreaders support IHAVE. Articles sent using IHAVE should contain all required headers, including Date

Re: uudecode driving me nuts

rocksolid.shared.helpdesk

Posted: 4 Months 15 Days ago by: trw

def4 is NOW displaying embedded attachments (like def3 generates them) damn it

Re: uudecode driving me nuts

rocksolid.shared.helpdesk

Posted: 4 Months 15 Days ago by: trw

10 s after I posted I realized that the file to decode was not named correctly....thanks for all your help :-] def4 is not displaying embedded attachments (like def3 generates them)

uudecode driving me nuts

rocksolid.shared.helpdesk

Posted: 4 Months 15 Days ago by: trw

uudecode -o /var/www/bbx/att/image.jpg /var/opt/msg/18329@test.com It produces a correct file by the name of image.jpg in the path that was given. The same line put in a shellscript which is run by www-data produces the file under the rig

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 4 Months 16 Days ago by: Retro Guy

I can't really answer that with any confidence. For me it's simply 'I don't need it. Other servers don't do it, why should I?' I know, not deep thought but I'm guessing it might be a common one. The end being that if you require a host t

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 4 Months 16 Days ago by: trw

Yes, that's true. What is the reason most servers do not allow it ? Is this a potential attack vector ? Yes, when doing POST the server suggests a message-id, but does not insist on it, you can still announce your own. Basically, rpost

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 4 Months 16 Days ago by: Retro Guy

If your prog requires the server to allow IHAVE, you limit yourself to what servers you can connect to. Many (most?) won't allow it. Also rslight server doesn't even support it. I think you already posted that you found you can set the

Re: Bracket Match Not Found

rocksolid.shared.helpdesk

Posted: 4 Months 16 Days ago by: Retro Guy

The brackets look ok in my editor (vi). This is assuming that it's all one line, not broken into two lines. When you run it, what get's echoed, text 1, 2 or 3? While you're testing, echo all sorts of stuff (and delete it later). Like

Re: Bracket Match Not Found

rocksolid.shared.helpdesk

Posted: 4 Months 16 Days ago by: trw

That's what this group was created for. Might I suggest to follow some of the guides in here: https://stackify.com/php-debugging-guide/ While i agree that some stuff should not be shared, the problem I see with your approach (of chan

Bracket Match Not Found

rocksolid.shared.helpdesk

Posted: 4 Months 16 Days ago by: Anonymous

Hey. If you read some of my previous posts, like "Notice: Undefined Variable" and "Notice: Undefined Variable (continued)", you know that I had some difficulty with code that I wrote. One problem mentioned is that I get no error logs when

Re: Posting an article with telnet - solved

rocksolid.shared.helpdesk

Posted: 4 Months 16 Days ago by: trw

Ok, in the script it was necessary to filter out the leading tabs, done with <<-%end (with a "-") instead of <<%end (without the "-") Now it is working from the script, so this message should arrive at def4 and rocksolid.2 at about the sam

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 4 Months 16 Days ago by: trw

Command: rpost $newsserver -U $username -P $password <<%end $(<./msg/668db00cef8eb620785984b9be4716a2) %end Output: Using Port 4567 Official host name: 192.168.1.1 Connected to 192.168.1.1 200 rocksolid3 InterNetNews NNRP server INN 2.

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 4 Months 17 Days ago by: trw

would it be a problem to enable IHAVE on an inn2 ? the advantage would be that the message-id could be predefined as thus known to the code. or maybe i could achieve the same with POST ?

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 4 Months 17 Days ago by: trw

The script is garbled up of course. I can upload it somewhere if someone wants it.

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 4 Months 17 Days ago by: trw

yes, rpost was discussed before, see here: http://x5qrtsbiebrxj65t.onion/index.php?t=msg&goto204 i still don't have it on my server (running debian buster), but now i realize it is a part of suck, so i will give it a try. the target of

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 4 Months 17 Days ago by: trw

Many thanks, that worked now. I could post a message from this little script here (see the test group for results). #!/usr/bin/expect #set ip "127.0.0.1 119" set ip "192.168.1.189 7000" spawn "/bin/bash" send "telnet $ip " sleep

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 4 Months 17 Days ago by: trw

281 Authentication succeeded post 340 Ok, recommended message-ID From: testos 7 Subject: testme Newsgroups: rocksolid.shared.test without body saying Body: .. 441 From: address not in Internet syntax post 340 O

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 4 Months 17 Days ago by: Retro Guy

I use rpost for things like nocem messages and anything I need to send from a file or automated. It works well for me. I do this in a bash script.

Re: Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 4 Months 17 Days ago by: Retro Guy

I think if you remove the 'Body:' line it may work. That line is part of the headers and appears as a header with no content. Try to just remove that line and see what happens. Finding the end of the headers is simply finding the first

Posting an article with telnet

rocksolid.shared.helpdesk

Posted: 4 Months 17 Days ago by: trw

https://www.oreilly.com/library/view/linux-network-administrators/1565924002/ch22.html https://tools.ietf.org/html/rfc3977#section-6.3.1 Connecting to an inn2 server, I get: Escape character is '^]'. 200 rocksolid3 InterNetNews NNRP serv

Re: Notice: Undefined Variable (continued)

rocksolid.shared.helpdesk

Posted: 4 Months 17 Days ago by: Retro Guy

Sounds like $_SESSION['captcha_code'] is not set. I would echo the values of variables where I plan to use them for testing, this makes it easy to see what variable is not correct. Then you need to trace back why a variable's value is i

Re: Notice: Undefined Variable (continued)

rocksolid.shared.helpdesk

Posted: 4 Months 17 Days ago by: Anonymous

Thanks for the advice! Following this code with the captcha parts, I got "Error: user_name, password or captcha_code not set". To analyze even further, I decided to remove $_POST['code'] === $_SESSION['captcha_code'] and

Re: Notice: Undefined Variable (continued)

rocksolid.shared.helpdesk

Posted: 4 Months 18 Days ago by: Retro Guy

It appears you are setting $q to your query under a certain condition (if statement), then sending the query whether $q was set or not: if(isset($_POST['register'])){ $user_name = $_POST['user_name'] ; $password = $_POST['pass

Notice: Undefined Variable (continued)

rocksolid.shared.helpdesk

Posted: 4 Months 18 Days ago by: Anonymous

Hello. This is a continuation of all the errors that I'm getting in code of mine. I was finally able to solve the _SESSION problem, but there was also another error that came below _SESSION, which was "Notice: Undefined Variable: q". After

Re: Notice: Undefined variable:

rocksolid.shared.helpdesk

Posted: 4 Months 18 Days ago by: Anonymous

It is as long as you session_start() https://errorsea.com/what-is-the-php-session-and-how-to-use-_session/

Re: Notice: Undefined variable:

rocksolid.shared.helpdesk

Posted: 4 Months 19 Days ago by: Anonymous

Are you sure ? I thought $_SESSION is a superglobal.

Re: Notice: Undefined variable:

rocksolid.shared.helpdesk

Posted: 4 Months 19 Days ago by: Retro Guy

I somehow missed the bottom of your post where you say it's _SESSION that's undefined. Do you have session_start() also in index.php? Without it you won't have $_SESSION variables available.

Re: Notice: Undefined variable:

rocksolid.shared.helpdesk

Posted: 4 Months 19 Days ago by: Retro Guy

Usually the log would tell you which variable is undefined. Then you know which variable you need to trace back to see when it should get defined. Does the log provide this info?

Re: Could Not Open Font

rocksolid.shared.helpdesk

Posted: 4 Months 19 Days ago by: trw

and don't forget to advertise your sites address here, once you have it done :-)

Re: Could Not Open Font

rocksolid.shared.helpdesk

Posted: 4 Months 19 Days ago by: trw

Good you could get it solved, and thanks for updating on the final solution. cheers trw

Could it be a typo ?

rocksolid.shared.helpdesk

Posted: 4 Months 19 Days ago by: trw

session_start(); cheers trw

Re: Could Not Open Font

rocksolid.shared.helpdesk

Posted: 4 Months 19 Days ago by: Anonymous

Solved! Apparently, I was using the wrong path the entire time... Thank you for trying to help me with the problem, as I got the answer from a post here.

Notice: Undefined variable:

rocksolid.shared.helpdesk

Posted: 4 Months 19 Days ago by: Anonymous

index.php: